FrameMaker 10

For the Novice Technical Writer

Kirstyn Costa
Allison Rocheleau
Sadie Trombetta
Acknowledgements

We would like to thank all of the students from the English 381, 382 and 391c classes for their support and feedback during this project. We really appreciated the encouragement.

We would also like to thank Professor Solberg for her knowledge and assistance. Without her, we would not have been able to create this manual.

Sincerely,

Kirstyn Costa, Allison Rocheleau, and Sadie Trombetta
Introduction

Welcome to FrameMaker 10 for the Novice Technical Writer!

What can I find in this guide?

The goal of this guide is to provide professionals, mainly technical writers, with information on the basic to intermediate tasks of FrameMaker 10. This guide includes a range of topics that will help greatly in your career as professionals.

The manual is task-oriented, which means that it is geared towards one specific task. In this case, it is the creation of a book type document. The four chapters of this manual focus mainly on the creation, the design, and the publishing of such a document.

How do I use this manual?

Chapter 1 is a basic introduction to FrameMaker. Chapters 2 through 4 are detailed instructions on how to format documents, how to insert graphics into documents, and how to get your document ready for publishing. Should you need to find a specific topic, there is a table of contents at the start of this manual, and there is also an index at the back that lists topics alphabetically.
# Table of Contents

**Chapter 1: Introduction** .................................1
- What is FrameMaker? ........................................2
- Setting Up Your Workspace ..............................3
- What are Templates, and How Do I Find Them? ........5

**Chapter Two: Creating a Book** .......................6
- Using the Book Panel .......................................7
- Working With Master Pages .............................8
- Formatting Character and Paragraph Tags ...............9
- Inserting and Formatting a Table ......................11
- Adding Text to a Table ...................................12
- Adding Page Numbers ...................................13
- Using Spell Check and Find/Change .................14
- Creating an Index ..........................................15
- Formatting an Index ......................................16

**Chapter 3: Getting Creative** .........................17
- Using Color ..................................................18
- Working With Drawing Tools ..........................19
- Working With Selection Tools ........................20
- Drawing Shapes .............................................21
- Importing Graphics .......................................22
- Adding Anchored Frames ...............................23
- Editing Graphics ..........................................24
- Creating Callouts .........................................25

**Chapter Four: Finishing Up** .........................26
- Printing .......................................................27
- Saving as a PDF ............................................28
- Publishing as an HTML document .................29

Index .....................................................................30
Chapter 1

Introduction

What is Adobe FrameMaker 10?
Setting up your work area
What are templates, and how do I find them?
What is FrameMaker?

Adobe FrameMaker is a powerful desktop publishing program used by technical writers everywhere. It's powerful, stable, and allows its users to create consistent documents, even when there are multiple authors. Unfortunately, also has a reputation for being quite tricky to work with, but only because it is quite a large program and there are so many functions to learn.

FrameMaker is useful when authoring books, memos, quick start guides, or even thousand page user's manuals. It is especially helpful for longer documents, as users can quickly create master pages and templates off of which all other pages of the document will be based. This makes for faster publishing, quicker turn around, and a more productive, less frustrated tech writing team.

FrameMaker is also good with single sourcing. Documents can be exported as ready for print documents, as PDFs, HTML, XML, or ready for integration with content management systems (CMS). Through Structured FrameMaker, users can create documents following XML and DITA (Darwin Information Typing Architecture) structures which include meta data and attributes. If all of that sounds foreign to you, don't worry, this guide will only be covering Unstructured FrameMaker, which is most common for documents which are meant for print publication.

With its vast amount of functionality, FrameMaker is one of the most important programs for new or aspiring technical writers to learn. Even if your new job won't require you to use it, being familiar with its interface will be helpful in using other publishing software like InDesign or MadCap Flare. And once you learn FrameMaker, every other program will seem like a breeze. So let's open up FrameMaker and get started...
Setting Up Your Workspace

When you open FrameMaker for the first time, you have the option to open FrameMaker (unstructured), or Structured FrameMaker. For our purposes, we will be using FrameMaker (unstructured). It is less complex, and easier to learn before moving to Structured interface.

After you select to open FrameMaker, a Welcome Screen opens. Before you tell FrameMaker what you will be working on (a document or a book), look at the Preferences. On the Menu Bar that runs along the top of the FrameMaker Window, click on File > Preferences > General. The Preferences dialogue box opens. In this dialogue box, you can change:

- Product interface (structured or unstructured FrameMaker)
- Auto back-up & auto-save
- Show file translation errors
- Show Greek screen text smaller than the pointsize you set for each text box
- Monitor size
- Embed Adobe Flash files, 3D objects, or multimedia objects as bitmap images in your PDF
- Checkout HTTP (HyperText Transfer Protocol) Files on Open, which allows you to collaborate on files saved on a remote WebDAV server, as well as upload your files to the remote server upon save
- Auto spell-check, which will underline spelling and grammatical errors in your document, and give you the option to fix them by right-clicking the underlined error
- Cross-platform file naming, if your file will be opened later on with a UNIX of Macintosh platform
- Network file locking, which warns you if another user has the same document open
- Remember missing font names, which saves font styles for when the document is open on a computer that does not have the font used in your document

To create a new document, on the Welcome Screen, click New Document, or from the Menu Bar, click File > New > Document. The New dialogue box opens. Click the Portrait option at the top of the dialogue box under the Use Blank Paper option. A blank document opens.
The first thing to look at is the Menu Bar at the top of the FrameMaker window. It includes tabs such as File, Edit, Format, View, and more. By clicking on any of these options, a drop-down menu will appear below giving you different options to work with. It is important to note that the Menu Bar changes when you are dealing with different types of documents or files.

An important feature of the Menu Bar is the View tab. Click on View > Toolbars to explore the different toolbar options. These different toolbars give you different options to work with. You have the option to Show All or Hide All toolbars, or you can click on any of the other options to show or hide each toolbar. Also located under the View tab, you can select to view a Ruler, Symbols, or Text Frame Border. Having these options selected will make formatting your document easier.

At the bottom of the FrameMaker window is the Status Bar. In the left-hand corner of this bar, it says Flow: ____, which tells you what tag you are working in within your document (we will discuss tags in Chapter 2). The Status Bar also gives you the options of zooming in and out of your document, and moving through it by skipping ahead to different pages.

At the top right-hand corner of the Menu Bar, there is the Workspace Switcher. The workspace controls the different pods and panels that appear on the FrameMaker window. We will talk more about pods and panels later, but they are essentially the different tool options you have for working with your document. The different Workspace options are Authoring, Design, Manage Graphics, and Review. There is also an option for a Blank workspace, which hides all pods and panels from the FrameMaker window. These workspaces are important because they allow you to modify them to your own preferences, save new workspaces, and reset them back to their original settings.

Depending on which workspace you have selected, different pods and panels will appear. Pods and panels are different arrangements and groups of elements and tools in your workspace. Panel dialog Boxes are docked on the right-hand side of the FrameMaker window, and can be minimized, grouped, stacked, grabbed, and removed from view. Pod dialog Boxes are docked on the bottom of the FrameMaker window.

Figure 3: The View and Toolbar selection window.

Figure 4: The Workspace Switcher.
What are Templates, and How Do I Find Them?

FrameMaker comes with standard templates for memos, letters, reports, newsletters, and books. A template is a good place to start if you aren’t sure of your design or are looking to quickly make a document.

To find Templates in FrameMaker:

2. Make sure Templates appears in the Look in field. The categories of templates appear below in the window. See Figure 1 for details.

*For example, the book templates are in the "Book" category, and the memo template resides in the "Business" category.*

3. Explore the different types of templates by clicking on the categories. See Figure 2 for details.
4. Select the template that you would like to use.

Figure 1: Finding Templates

Figure 2: Exploring template types
Chapter 2
Creating a book

Using the Book Panel
Working with Master Pages
Formatting Character and Paragraph tags
Inserting and formatting a table
Adding text to a table
Adding page numbers
Using Spell Check and Find/Change
Creating an index
Formatting an index
Using the Book Panel

The book panel becomes visible any time you open an existing book or create a new one. From this panel, you can add or remove documents, reorder files, and save your book so you don’t lose all your hard work. Follow this guide to become a bit more familiar with using the book panel.

1. Once a book has been saved, its name can be seen at the top of the book panel.
2. Add a file. To use this option, the file must have already been saved.
3. Add a folder. This can be used for grouping files that may or may not be used in the final product.
4. Add a group to your book. Groups can be helpful for arranging different chapters or sections of your book.
5. Save your book. This can also be done by clicking File > Save Book in the menu bar.
6. Delete a file by selecting the file by clicking on it once and clicking on this icon.
7. Update book. This is useful when table of contents or indexes are changed.
8. Use the arrow keys to reorder the contents of your book. You can also reorder files by clicking and dragging them to the desired location within the book.
9. Display heading text. This icon toggles whether you view the heading text or the file name of each file in the book panel.
10. Find/Change. This allows you to search your book for a word, then change that word for something else, if desired.
Working With Master Pages

Master Pages are essential when working with larger documents. By using Master Pages, you can apply running page numbers, layouts for several different types of pages, and many other formatting options that normally become increasingly difficult as your document increases in size. This section will guide you through some of the basics of using Master Pages, and how to utilize them to their full potential.

1. From the menu bar, go to View > Master Pages to enter Master Pages view.

2. From the menu bar, go to Format > Page Layout > Pagination.

3. In the Pagination window, check the Double Sided bubble. Make sure 1st Page Side is set to Right. Click Set. This will create both a right and left master page to work with. (See Fig. 1)

4. Click the arrow buttons at the bottom of the workspace to switch between the right master page to the left. (See Fig. 2)

5. In the Header frame, enter the text for a running header. This may be a document title or author name. Format as normal text. (See fig. 3)

6. Insert the cursor into the Footer frame. On the menu bar, click Format > Headers & Footers > Insert Page #. The page number shows up as a # symbol while in master page view.

   **Note:** To insert other header or footer items, from the menu bar, click Format > Headers & Footers > Insert Other. The Variables panel opens, from which items such as a Chapter Title Name can be inserted into the header or footer by double clicking on the variable name.

7. To create a column layout, insert the cursor into the Body frame.

8. On the menu bar, click Format > Page Layout > Column Layout.

9. In the Column Layout window, set the column options. Click Update Entire Flow when finished. (See fig. 4)

10. When finished making changes to the master pages, return to body pages view by clicking View > Body Pages on the menu bar.
Formatting Character and Paragraph Tags

Character and Paragraph tags are sets of formatting characteristics that change to look of your text. The tags are what make FrameMaker such a desirable software to create technical documentation in because the tags allow you to format your documents and books more consistently and easily. The tags allow you to save time, keep your document consistent even with multiple authors working on it, and it allows you to modify the tag once and apply the change to all parts of your document or book with that tag. **Paragraph Tags** change the format of the entire paragraph you have selected. Some examples of **Paragraph Tags** include Header, Footer, and Bullets. **Character Tags** allow you to make changes to a word or a few words within a paragraph without making changes to the entire paragraph's format. Some examples of **Character Tags** include Emphasis and Note.

To begin working with paragraph and character tags, switch your Workspace Switcher to Designer mode. A right screen panel appears. There a three tabs that appear at the top of the panel:

1. Paragraph Designer, which allows you to create and manipulate paragraph tags
2. Character Designer, which allows you to create and manipulate character tags
3. Table Designer, which allows you to create and manipulate tables (we will return to tables in the later chapters)

First, let’s look at how to create a tag:

1. Click the **Commands** button at the bottom left-hand corner of the paragraph or character design panel.
2. Click **New Format**. A dialog box opens.
3. Type in the name for the tag you are creating, such as the character tag Note or the paragraph tag Sidehead.
4. Select or deselect **Store** if you wish to save this tag.
5. Select or deselect **Apply** if you wish to apply the new tag to the current text your cursor is on.
6. Click Create.

![Figure 1: The Designer Panel and Paragraph Designer dialog box.](image1)

![Figure 2: The New Format dialog box for creating new tags.](image2)
To change the settings of your new paragraph tag, go to the paragraph designer panel. Notice at the top there are seven icons to choose from. Each of them offer different options for formatting:

- **Basic Properties Tab** allows you to adjust things like indents, alignment, linespace, and tab stops.
- **Default Properties Tab** allows you to adjust the typographical characteristics of the paragraph tag, including family, size, angle, and color.
- **Pagination Properties Tab** allows you to adjust where the paragraph will be placed including where it starts, what format to have (in column or side head alignment, for example), and an as in option.
- **Numbering Properties Tab** allows you to set up automatic properties such as chapter numbers, bullets, and step numbers. This also includes the **Building Blocks** options, which are codes you can insert into the Autonumber Format field.
- **Advanced Properties Tab** allows you to set characteristics like hyphenation, lines above and below the paragraph, as well as justification.
- **Asian Properties Tab** is used when writing documents in an Asian language.
- **Table Cell Properties Tab** allows you to set properties for the text within a table, including the cell alignment and margins.

The character designer panel does not include multiple tabs, but instead has the basic options including font family, size, angle, and color on the main panel.
Inserting and Formatting a Table

Tables can be very helpful when creating a document that has a lot of data. They help display data in a neat and organized fashion. Follow these steps to include a table into your book.

1. Open the document in which you would like to place a table.
2. Click on Table > Insert Table on the menu bar.
3. In the box that appears, choose either Format A or Format B on the left side of the box.

You can edit the number of columns and rows on the right side of the box if either format does not fit your needs. See figure 1.

Tip: Keep the Heading Rows at 1, as this is the row where the title of your table goes.
4. Click Insert to place the table into your document.

Figure 1: Insert Table dialog and options box
Adding Text to a Table

In order for your table to be useful, you should add text to it. In order to add text, you need to know how. Follow these steps to make your tables worthwhile.

1. Open the document that contains the table to which you would like to add text.
2. To add a title to your table, click after the colon in the table title, press the Space bar, and then proceed to type your desired title.
3. Press TAB to move into the first heading cell. Type the title of this column.
4. Press TAB to move into the next heading cell. Type the title of this column.
   
   Continue to press TAB across the heading cells to create titles for as many columns that your table contains. The example below contains two heading cells because it has two columns. See figure 1.

5. Press TAB to move to the first cell in the first body row. Type your desired text.

   Continue to press TAB across each cell to add text.

<table>
<thead>
<tr>
<th>Table 1: Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heading $</td>
</tr>
<tr>
<td>Body $</td>
</tr>
<tr>
<td>body $</td>
</tr>
<tr>
<td>body $</td>
</tr>
<tr>
<td>body $</td>
</tr>
<tr>
<td>body $</td>
</tr>
<tr>
<td>body $</td>
</tr>
<tr>
<td>body $</td>
</tr>
<tr>
<td>body $</td>
</tr>
</tbody>
</table>

Figure 1: Adding Text
Adding Page Numbers

Page numbers provide an added level of organization to your book. They ensure that your readers know exactly where they are within your book, and are very helpful when adding a table of contents or index later on.

2. Scroll to the bottom of the chapter page and double-click into the Footer area of the page.
3. Make sure that your cursor is still in the footer, then click Special > Variables on the menu bar.
4. Click Current Page # in the Variables pod.
5. Click Insert Selected Variable. This inserts the # symbol into the footer.
6. Place your cursor in front of the # symbol, then press TAB on your keyboard. This centers the number in the footer.

**Repeat these steps in the right and left Master Pages**

To return back to the Body Pages, click View > Body Pages.

Figure 1: Insert Page Numbers
Using Spell Check and Find/Change

When editing your drafted documents, you may find that it is important to know how to use the Spell Check and Find/Change tools in FrameMaker so that you may ensure that every word within your document is correct.

For Spell Check:
1. Open your document
2. Click on the Spell Check icon (seen below) in the menu bar, or click Edit > Spelling Checker

Note: If there are any misspelled words in your document, they appear in the window of the dialog box that appears. If there are no spelling errors, the window is empty.

3. If there are any misspelled words, click on the correct spelling inside the dialog box, then click Correct. You may also click Allow in Document to keep the selected word, or click Learn to add the word to the dictionary.

For Find/Change:
1. Click Edit > Find/Change.
2. Enter the word you would like to find under the Find field. Click Find. The first instance of that word is highlighted.
3. Enter the word you would like to replace it with under the Change field. Click Change. The highlighted word is now your replaced word.

You can also click Change All to change every instance of the found word with the changed word. See figure 1.
Creating an Index

An index is helpful whether you’re making a 20 page user’s manual, or a 1,000 page quick start guide. Creating and generating your index may be a little time consuming, but your readers will thank you for all of your hard work.

1. Select the text to be added to the index.
2. Go to Select > Marker in the menu bar (see fig. 1). The Marker Panel opens with the selected text in the Marker Text field.
3. From the Marker Type drop down menu, choose Index (see fig. 2).
4. Click New Marker.
5. Create a new marker for all other words to be added to the index.
6. Go to Special > Standard Index. Click Yes when asked to create a standalone Standard Index. The Set Up Standard Index window opens.
7. In the Include Markers of Type, include only Index markers.
8. Click Set.
9. Format the index using the steps in the next section.

Figure 1: Creating an Index Marker

Figure 2: Creating an Index Marker
Formatting an Index

You've generated a pretty decent index at this point, but it certainly doesn't look professional, does it? This section will walk you through a few easy steps to making your index look a little cleaner, easier to read, and more like the indexes you're used to seeing in professionally published books.

1. Open the previously generated index file.
2. Change the spacing between the identifying letter and its corresponding group of terms by placing the cursor next to the first letter - its paragraph tag should be GroupTitlesIX.
3. In the Paragraph Designer, Basic Properties section, click the arrow next to the Above Pg field and choose 2 lines. Click Update All. This creates two lines of space between each letter and the previous group of terms.
4. In the Paragraph Designer, Basic Properties section, click the arrow next to the Below Pg field and choose 1 line. Click Update All. This creates one line of space between each letter and its own group of terms (see fig. 1).

NOTE: By updating only the Group Titles spacing, you avoid having excessive spacing between each line of each new term.

5. Format the Group Titles and the Level1 terms as desired.
6. Add a title and format as desired using the Paragraph Designer. Be sure to use a different Paragraph Tag from the rest of the index, like Heading1.
7. To add a title in an index with a two column layout (see more on adding columns in Master Pages section), center the title on the page by setting the alignment to Center in the Basic Properties section of the Paragraph Designer. Click Update All. In the Pagination section of the Paragraph Designer, click the Across all Columns radio button. Click Update All (see fig. 2).
Chapter 3: Getting Creative

- Using color
- Working with drawing tools
- Working with selecting tools
- Drawing shapes
- Importing graphics
- Adding anchored frames
- Editing graphics
- Creating callouts
Using Color

Adding color to your book document can make your book more interesting and more professional, if used correctly. Be careful to choose colors that aren’t too bright, and try not to use more than 2 or 3 colors, as this will make your document look childish or unorganized. The company you work for may also wish for you to use a certain color in your documents. FrameMaker allows you to add specific colors to the library so that you can use them throughout your documents.

To add a color to the color catalog:

1. Click View > Color > Definitions on the menu bar.
2. In the dialog box that appears, enter a new name for the color in the “Name” field.
3. Select a color model, and then enter the values for either RGB or CMYK color modes.
4. Click Add. This color is stored in the color catalog for future use.

To change font color:

1. Open the file to which you would like to add color.
2. Highlight the text that you would like to change.
3. In the Paragraph Designer, click on the Default Font button.
4. Click on the color drop down menu.
5. Select the desired color.

Note: To change the background color of text, check the box next to the words “Background Color” and then select the desired color from the drop down menu.
Working With Drawing Tools

In order to work with your **Drawing Tools**, you must first make sure you have the **Graphics Toolbar** open. To do so, click **View > Toolbars** > **Graphics Toolbar**, or click **Graphics > Tools**. The **Graphics Toolbar** will appear in a panel at the left-hand side of the FrameMaker window.

The **Graphics Toolbar** has three basic types of tools:

- **Selection Tools** include the **Smart Select** tool that allows you to select text or objects, and the **Select Object** tool that allows you to select objects only.

- **Drawing Tools** include the **Line Tool**, **Arc Tool**, **Polyline tool**, **Freehand Curve tool**, **Rectangle tool**, **Rounded Rectangle tool**, **Oval tool**, **Polygon tool**, **Text Frame tool**, **Text Line tool**, and the **Graphic Frame tool**. To use these tools, click on the icon to select it and then begin drawing your shape in your document by holding down the left mouse.

- **Drawing Properties Tools** include **Set Fill Pattern**, **Set Pen Pattern**, **Set Line Widths**, **Set Line End Style**, **Set Dashed Line Pattern**, **Set Color**, **Set Tint**, and **Set Overprint**. To adjust any of these settings, click on the desired icon on the left hand side of the panel and a drop down menu will appear with different options. Click the option that you want, and the selected option will appear on the right hand side of the panel.

When working with these tools, it may be useful to use a grid. **FrameMaker** has two types of grids:

- The **Snap Grid** is an invisible grid that automatically attracts objects you are drawing to its grid lines. To turn this option on, click **Graphics > Snap** in the menu bar at the top of the FrameMaker window.

- The **Grid Lines** option will show **FrameMaker**’s visible grid. To view this option, click **View > Options** in the menu bar at the top of the FrameMaker window. Under the **Display** heading of the dialog box, and click **Grid Lines** to see the display options for a visible grid.
Working With Selection Tools
When working with a document with images and text, knowing how to use the selection tools can be helpful. The selection tools can help you move images and text easily. But be wary, don’t get the two of them confused.

Types of selection tools:
The Smart Select tool (Figure 1)
The Select Object tool (Figure 2)

Uses of each selection tool:
The Smart Select tool allows you to select text or objects.
1. Click on the Smart Select tool in the toolbar.
2. Press CTRL, and click on the object that you would like to select.

The Select Object tool allows you to select objects, but not text.
1. Click on the Select Object tool in the toolbar.
2. Click on the object that you would like to select.
**Drawing Shapes**

FrameMaker is a publishing tool and as such, it isn’t known for being great with graphics. For simple shapes, however, FrameMaker can work just fine. Follow these steps to make some simple graphics to spice up your book.

**First, to draw a closed shape:**

1. Click the closed shape icon (Rectangle, Rounded Rectangle, Oval, Polygon) you want from the Graphic Toolbar.
2. Place the cursor in your document where you wish to draw the shape. While holding down the left mouse, drag the mouse to size your object.
3. Release the mouse, and your shape appears in the document where you have drawn in.

**To draw a shape that is not pre-defined:**

1. Click on the polygon or polyline icon from the Graphics Toolbar.
2. Left-click in your document where you want the shape to start.
3. Drag the mouse where you want your shape to go next, and left-click the mouse. Continue this until you have the desired shape.

To end your shape, double-click the left mouse. Your shape appears in the document where you have drawn in.

*Figure 1: The closed shape icons for drawing ovals, rectangles, and polygons.*

*Figure 2: The Polygon and Polyline tools for drawing undefined shapes.*
Importing Graphics

There are two ways to import graphics into your FrameMaker document. First, you can copy and paste the image file into your document. The graphic then becomes a part of your document, and if the original image file is lost or changed, the graphic within your document is unaffected. This does, however, increase the overall size of your document. Secondly, you can Create a Reference to an image file. This means that the image file itself is not in your document, but a link to it is created so the graphic appears. This keeps your overall document size smaller. If the original image file is lost or altered, the graphic in your document will be affected.

To import a graphic into your document:

1. Position the cursor in the document where you want the graphic to go, or if you have already created an anchored frame for it, click the desired anchored frame.

2. On the menu bar at the top of the FrameMaker window, click File > Import > File. A dialog box opens.

3. Select whether you would like to Import by Reference or Copy Into Document by selecting the appropriate button at the bottom of the dialog box.

4. Find the graphic you wish to import. Click Import.

5. The Imported Graphic Scaling dialog box opens.

6. Select the dots per inch (DPI) for your graphic. Try to avoid the “Fit In Selected Rectangle” option, because graphics tend to become distorted if force-fitted.

7. Click Set. The graphic is imported into your document.

Figure 1: The Imported Graphic Scaling dialog box.
Adding Anchored Frames

Anchored frames help you to place graphics into your documents, crop graphics, and mask graphics. You can use anchored frames in your body pages, reference pages, or master pages. You add an anchored frame to a document before importing a graphic.

To insert an anchored frame into your document:

1. Click into the document you wish to add the anchor frame into.
2. In the menu bar, click Special > Anchored Frame. A panel will appear on the left-hand side of the Frame Maker window.
3. Click the arrow in the Anchoring Position field to see a drop-down menu with positioning options, and click on your desired selection.
4. Click the arrow in the Alignment field to see a drop-down menu with alignment options, and click on your desired selection.
5. Below the Alignment field, select Cropped if you want your graphic to be cut off by the borders of the text frame of select Floating if you want your graphic to be placed elsewhere if there is not enough room where you place it.
6. Set your desired Width and Height for your anchored frame.
7. Click New Frame, and your anchored frame will appear in your document.
Editing Graphics

Now that you’ve imported a graphic into your document, you might be wondering what’s next. Well, wonder no more. You can edit your graphics in all sorts of ways right in FrameMaker. This section will guide you through resizing, cropping, rotating, and reordering your graphics.

1. Set the workspace to Manage Graphics.
2. Insert a graphic into a document following the steps in the Importing Graphics section on page 22.
3. Resize the graphic by selecting it and dragging the black boxes to the desired size. Or select the graphic then go to Graphics > Scale in the menu bar and input the desired options.
4. Crop the graphic by clicking on the Place Graphic Frame button in the Tools palette. Draw a graphic frame inside the anchored frame (See Fig. 1). Drag the graphic into the graphic frame. Move the graphic to the desired position and resize the graphic frame to the desired size (See Fig. 2).
5. Group multiple graphics so they are treated as one object by selecting them and clicking Graphics > Group in the menu bar.
6. Change the order of multiple graphics to create a layered effect by selecting a graphic and clicking Graphics > Send to Front in the menu bar to bring it to the foreground, or Graphics > Send to Back to send it to the background.
7. Rotate the graphic by selecting it and clicking Graphics > Rotate in the menu bar. In the Rotate Selected Objects dialog box, type the degree to rotate the object in the Rotate By field, and select either the Clockwise or Counterclockwise radio button. Click Rotate.
Creating Callouts

While you may be tempted to create callouts for your images in Photoshop and paste the entire image, callouts and all, into FrameMaker, there are ways to add callouts to your document right in FrameMaker without having them look entirely hideous. Plus, if you need to edit your callouts, it will be so much easier to edit them right in FrameMaker than to start all over again in Photoshop. So, try to get over your fears and see if you can find some techniques for making callouts in FrameMaker that are still as aesthetically pleasing as you're used to making.

1. Set the workspace to Manage Graphics.
2. Place a graphic into the document by following the steps in -?-. 
3. Click the Set Line End Style button in the graphics tool bar.
4. Choose from No Arrow for a cleaner look, Arrow at Head to add an arrow where the line ends, Arrow at Tail to add an arrow where the line starts, or Arrow at Both Ends. The Selected Line End box next to the Set Line End Style button shows which line end is currently selected.
5. Select the line width by clicking the Set Line Width button.
6. Select line color by clicking the Set Color button.
7. Draw a line by clicking the Draw a Line Button and clicking with the mouse on the document and dragging the line to the desired point. Release the mouse button once the line is the desired length. To edit a line, select it and drag the squares to resize or drag the entire object to move it.
8. Add text by clicking the Draw a Text Line tool.
Chapter 4
Finishing up

Printing
Saving as a PDF
Publishing as an HTML document
Printing

Printing single documents in FrameMaker is just as simple as with any other program. Printing a book, on the other hand, takes a couple of extra steps. To make sure you don’t mess anything up when you’re in the final stages of your project, follow these steps to print your book.

1. Open the book file to be printed.
2. Open all of the files in the book by holding down the shift key and clicking File > Open all Files in Book on the menu bar.
   
   NOTE: Opening all files of your book speeds up the updating process and is good practice any time you update or interact with all of the files in your book at once.

3. Print all of the files in the book by clicking File > Print Book on the menu bar. Choose print options in the Print Book dialog box. (See fig. 1.)

4. Print select files in the book by holding CTRL on the keyboard then selecting the files to be printed in the book panel. Click File > Print Select Files on the menu bar. Choose print options in the Print Selected Files dialog box. (See fig. 1.)

5. Click Print.
Saving as a PDF

When you have finished your book, perhaps you would like to upload it to a web site, or send it to a printer for printing. Saving your book as a PDF allows you to send a non-editable file to a printing company, which ensures that your final product will not be changed in any way.

1. Open the file that you would like to convert to PDF form.
2. Click File > Save as PDF.
3. Click Save.
4. In the pop up menu that appears, select your desired settings for the PDF file.

**Note:** If you would like to view your PDF after publishing it, make sure to select the box in the pop up menu next to “View Generated PDF in Acrobat”.

**Note:** If you would like to publish a few pages of your book instead of the whole document, enter the page numbers in the Page Range field in the menu. If you would like to publish all of them, select All in the Page Range field.

5. Click Set.

![PDF Pop Up Menu](image)

*Figure 1: PDF Pop Up Menu*
Publishing as an HTML document

When you know how to publish your book as an HTML file, it allows you to be able to publish the content easily online to a website. These steps are easier than you might think, so follow along and you’ll be generating web content in no time.

1. Step 1: Open the file that you would like to convert to HTML form.
2. Step 2: Click File > Save As on the menu bar.
3. Step 3: Rename your file, and make sure to type .htm or .html as the file extension.
4. Step 4: In the Save As Type field, click on the arrow at the end of the box, and select HTML (*.htm).
5. Step 5: Click Save.

Note: If a pop up message appears asking if you would like to save the file in this format, click Yes. If another message pops up saying that a paragraph tag isn’t in your catalog and is asking if you would like to add it, click Yes.

![Save As Type drop down menu.](image)
# Index

| A | Anchored Frames | 23 |
| B | Background color | 18 |
| B | Body Pages | 8 |
| B | Book Panel | 7 |
| C | Callouts | 25 |
| C | Character Designer | 9 |
| C | Character Tags | 9 |
| C | Color | 18 |
| C | Color catalog | 18 |
| C | Column | 8 |
| D | Drawing Properties Tools | 19 |
| D | Drawing Tools | 19 |
| E | Editing Graphics | 24 |
| F | Find/Change | 14 |
| F | Font color | 18 |
| F | Footer | 8 |
| F | Formatting a Table | 11 |
| F | Formatting an Index | 16 |
| F | Freehand Curve tool | 19 |
| G | Graphic Frame tool | 19 |
| G | Grid Lines | 19 |
| G | Grids | 19 |
| H | Header | 8 |
| H | HTML | 29 |
| I | Import graphics | 22 |
| I | Index | 15 |
| I | Insert Table | 11 |
| L | Line Tool | 19 |
| M | Marker | 15 |
| M | Master Pages | 8 |
| O | Oval tool | 19 |
| P | Page Numbers | 13 |
| P | Paragraph Designer | 9 |
| P | Paragraph Tags | 9 |
| P | Polygon tool | 19 |
| P | Polyline tool | 19 |
| P | Printing | 27 |
| P | Printing a book | 27 |
| P | Publishing as an HTML document | 29 |
| R | Rectangle tool | 19 |
| R | Rounded Rectangle tool | 19 |
| S | Save as PDF | 28 |
| S | Select Object tool | 19, 20 |
| S | Selection Tools | 19, 20 |
| S | Set Color | 19 |
| S | Set Dashed Line Pattern | 19 |
| S | Set Fill Pattern | 19 |
| S | Set Line End Style | 19 |
| S | Set Line Widths | 19 |
| S | Set Overprint | 19 |
| S | Set Pen Pattern | 19 |
| S | Set Tint | 19 |
| S | Shapes | 21 |
| S | Smart Select | 19 |
| S | Smart Select tool | 19, 20 |
| S | Snap Grid | 19 |
| S | Spell Check | 14 |
| S | Structured FrameMaker | 2 |
| T | Tables | 11 |
| T | Templates | 5 |
| T | Text Frame tool | 19 |
| T | Text Line tool | 19 |
| U | Unstructured FrameMaker | 2 |
| V | Variables | 8, 13 |